This script creates a new image by interleaving layers between layers of the current image. It covers two different modes of operations:
The top layer of each pair can be merged to the underlying layer with a given transparency and layer mode. The first set of layers comes from the calling image (the one through which the script is called).
In multiple-layer mode, the inserted layers come from another image already loaded in Gimp.
In single layer mode, the inserted layer can come from any loaded image (including the one used as a source for the base layers)
The script uses the selected layers in the calling image, and will not be enabled in the menus if there is only one selected layer. For multiple-layer mode both layer sets should hold the same number of layers.
The script only works on full-RGB or grayscale images.
The script is started by the Image > Interleave layers menus. This menu is disabled
if:
* The image is color indexed (GIF, and sometimes PNG). You need to convert the image to
full-RGB or grayscale mode first.
* There are no selected layers or only one selected layer in the image
(this script expects multiple layers as input)
If you deal with animations (in particular, GIFs) make sure that the images are not
optimized (layers marked with (combine)). If so, de-optimize the image with
Filters > Animation > Unoptimize. You can re-optimize them later.
If the image is color-indexed you have to convert it to full-RGB or grayscale before using the script.
Groups are supported in both the calling and the source image.
They are copied verbatim, and flattened if you use the merge option.
Warning: selecting a layer group is not the same as selecting a layer group and its child layers. In the first case you have one frame to copy, in the second you have three.
The output image is created with the same dimensions, type, and precision/encoding
as the calling image.
So the difference between interleaving layers from A above layers in B,
and interleaving layers from B under layers in A
is that in the first case the output image inherits its characteristics from B
and in the second case it inherits them from A.
The layers are copied to the output image with the size and offsets from their origin image.
Here is how you can easily achieve two frequent use cases:
Image > Canvas size, and:
File > Open as layers to load all the animation layers[Ctrl-A] to select all layers, and then to remove
a few layers (for instance the ones from the background) by Ctrl-clicking them). Move selected layers you can now move all the animations layersone of the layers, this will move all the chained layers.
as a whole.Interleave layers to insert the background image
under each layer of the animation.